読者です 読者をやめる 読者になる 読者になる

katorea memo

いろいろ

Inter-AS Option A

前回で無事MPLS VPN網を構築することができたので、今度はInter-ASについて構築してみる。
Inter-ASとは、MPLS VPN間の接続を可能とする方法で、構築方法は、四種類ほどあるので一つずつ確認していく。

NW構成はこんな感じ。
f:id:gemunopedy:20170428214314p:plain

本当はポリシーを合わせるために、AS65300のMPLS網のアドレスは10にするべきだったけど、
192で設定していたことにだいぶ後に気づいて直すのが面倒くさいのでこのまま。
後CSR8も本当はCSR9だけど面倒くさいからこのまま。

ゴールはCSR1からCSR8までpingが届くようにすること。

option Aの設定は非常に簡単。
Back-to-Back VRFということで、XR4とXR8のASBRにおいて、VRFを作成し、
VRF間をbgpなどでvpn情報を伝達できるようにするだけで設定は完了。
今回は何の問題もなくゴールまで達することができた。

XR4のconfig

hostname XR4
vrf USER1
 address-family ipv4 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
!
interface Loopback0
 ipv4 address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 vrf USER1
 ipv4 address 192.168.48.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 vrf USER1
 ipv4 address 192.168.45.4 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 10.0.34.4 255.255.255.0
!
route-policy pass
  pass
end-policy
!
router ospf 1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/2
  !
 !
!
router bgp 65200
 bgp router-id 4.4.4.4
 address-family ipv4 unicast
  network 4.4.4.4/32
 !
 address-family vpnv4 unicast
 !
 neighbor 3.3.3.3
  remote-as 65200
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 neighbor 10.0.34.3
  remote-as 65200
  address-family ipv4 unicast
   soft-reconfiguration inbound
  !
 !
 vrf USER1
  rd auto
  address-family ipv4 unicast
  !
  neighbor 192.168.45.5
   remote-as 65100
   address-family ipv4 unicast
    route-policy pass in
    route-policy pass out
    as-override
   !
  !
  neighbor 192.168.48.8
   remote-as 65300
   address-family ipv4 unicast
    route-policy pass in
    route-policy pass out
   !
  !
 !
!
mpls ldp
 interface GigabitEthernet0/0/0/2
 !
!
end

この設定をXR8にも実施すれば完了。

end-endでpingを打った時のパケットをキャプチャしてみる。

RR3のGi0/0/0/0では、MPLS識別ラベルとVPN識別ラベルが付与されている。
f:id:gemunopedy:20170508123636p:plain

XR4のGi0/0/0/2では、VPN識別レベルのみが付与されている。
これはPHP機能によるもの。
f:id:gemunopedy:20170508124106p:plain

XR8のGi0/0/0/0では、ラベルは付与されていない。
f:id:gemunopedy:20170508124217p:plain


次回はOption Bに挑戦。