katorea memo

いろいろ/まずはCCIE SP

Inter-AS Option D (AB)

Inter-AS最後のOption D (AB)の構築を行う。
Optin D (AB)の特徴は以下の通り。
・ASBR間はVRF
・mpbgpは1セッション

という感じに、Option DはAとBを組み合わせた感じのOptionとなる。
構成は以下の通り。
f:id:gemunopedy:20170525182048p:plain

r5(ASBR)のconfig

hostname r5
!
ip vrf a
 rd 1:1
 inter-as-hybrid next-hop 192.168.1.6
 route-target export 1:1
 route-target import 1:1
!
ip vrf b
 rd 2:2
 inter-as-hybrid next-hop 192.168.2.6
 route-target export 2:2
 route-target import 2:2!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip ospf 1 area 0
!
interface Ethernet0/0.1
 encapsulation dot1Q 1 native
 ip vrf forwarding a
 ip address 192.168.1.5 255.255.255.0
!
interface Ethernet0/0.2
 encapsulation dot1Q 2
 ip vrf forwarding b
 ip address 192.168.2.5 255.255.255.0
!
interface Ethernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.0.5 255.255.255.0
 mpls bgp forwarding
!
interface Ethernet0/2
 ip address 192.168.45.5 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
router ospf 1
!
router bgp 3
 bgp router-id 5.5.5.5
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 192.168.0.6 remote-as 4
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
  neighbor 192.168.0.6 activate
  neighbor 192.168.0.6 send-community extended
  neighbor 192.168.0.6 inter-as-hybrid
 exit-address-family
!
end

Inter-AS Option Dの設定は非常に簡単。
上記赤文字の二点を設定するだけでr1からr9へのpingが可能となる。
・vrfにinter-as-hybrid next-hopの設定を行う。
 next-hopは対向先のvrfのアドレスとなる。
・bgp neighbor設定でinter-as-hybrid設定を行う。
 ちょっとしか調べていないので、本当かまだ不明だが、該当インターフェースで「mpls bgp forwarding」を有効とすための設定ぽい。
 通信確立後、r5のinter-as-hybridの設定を削除しても通信は確立したままだった。

続いてXRでの構築に挑戦。
XRに関してはほとんどドキュメントを見つけることができなかったため、
ひとまずコマンドからinter-as-hybridの代わりとなるものを探してみるも見つからず。
もしかして特別なことしなくてもいけるんじゃないかと思ったがそんなことなく。
これまたかなりの時間を要した。
debugコマンドはまだ使いこなせないのでwiresharkを使いながら一つずつ問題解決していったが、どうしてもASBR間でつまずく。
そしてこんなのを見つける。
supportforums.cisco.com

心が折れたのと、Inter-ASに飽きたので、ひとまずOption DもIOSはできたのでこれで完了。
二週目の時に頑張ることにする。

次回は、MPLS TEあたりをやりたい。